Odd Sorting Issue - Adult (Performers)

To get bugs in the current release fixed, please report them here.
User avatar
Seneset
Posts: 5
Joined: Thu Jan 10, 2019 10:47 am

Odd Sorting Issue - Adult (Performers)

Postby Seneset » Thu Jan 10, 2019 11:34 am

I've noticed that new performers I add to the database manually (these are empty and have the blank icon still) or ones added via auto download from the "download video info" don't sort like the rest of my database. They do sort alphabetically but only in the last column that's visible and by themselves.

However, if I go into the effected performers profile under edit cast and use the "download cast info" button. Then refresh my Performers (Adult) list by going to another tab and coming back, they then sort properly into the rest of the list.

Image 01 is from just loading the sort by Performers (Adult) tab. Image 02 and 03 is after scrolling down.

List 01.jpg
List 01.jpg (311.55 KiB) Viewed 119 times
List 02.jpg
List 02.jpg (318.89 KiB) Viewed 119 times
List 03.jpg
List 03.jpg (331.28 KiB) Viewed 119 times
Last edited by Seneset on Fri Jan 11, 2019 4:52 pm, edited 1 time in total.

User avatar
admineazymojo
Site Admin
Posts: 1000
Joined: Wed Jan 02, 2013 9:36 pm
Contact:

Re: Odd Sorting Issue - Adult (Performers)

Postby admineazymojo » Thu Jan 10, 2019 11:39 pm

I'm not able to replicate this issue. Can you give me a step-by-step process so I can try to duplicate it? And be specific, when you say you add a new performer, tell me exactly what you're clicking to do that. Also, do you have any filters on?

User avatar
Seneset
Posts: 5
Joined: Thu Jan 10, 2019 10:47 am

Re: Odd Sorting Issue - Adult (Performers)

Postby Seneset » Fri Jan 11, 2019 2:14 am

admineazymojo wrote:I'm not able to replicate this issue. Can you give me a step-by-step process so I can try to duplicate it? And be specific, when you say you add a new performer, tell me exactly what you're clicking to do that. Also, do you have any filters on?


No filters are on, just the tag category set to Performers (adult).

When I manually add a new performer I've done it two ways. The first was clicking on the little i button that says "show video info, add tags, view cast" when you hover over it. From that menu, I use the little box underneath the Cast section. The second was right clicking a video's thumbnail and going to tags > add cast. In both cases the new name would show up with a blank icon. I wouldn't click the icon or add anything to the new profile.

From there if I didn't edit the profile at all (as I understand the profile would just have a name and nothing else) and I go to the to tag categories and selected Performers (adult) I'd see the sorting order I mentioned earlier after I scroll down.

User avatar
admineazymojo
Site Admin
Posts: 1000
Joined: Wed Jan 02, 2013 9:36 pm
Contact:

Re: Odd Sorting Issue - Adult (Performers)

Postby admineazymojo » Fri Jan 11, 2019 3:38 pm

I'm still unable to reproduce the issue doing the steps you described.

The screenshots you posted are also confusing. You say you have no filters on. In your 1st screenshot, the list appears to be a much shortened list of performers than the default. Did you delete a bunch of performers or is that view being filtered...possibly by 'assigned' tags only? You say the 1st screenshot is from just loading the performers, but that screenshot starts at J and the 2nd screenshot starts at A. Did you post them in the wrong order?

Also, how many 'Tags per page' are you showing?
And what is your 'Thumbnail %' display setting in the bottom right of the status bar?

User avatar
Seneset
Posts: 5
Joined: Thu Jan 10, 2019 10:47 am

Re: Odd Sorting Issue - Adult (Performers)

Postby Seneset » Fri Jan 11, 2019 5:00 pm

admineazymojo wrote:I'm still unable to reproduce the issue doing the steps you described.

The screenshots you posted are also confusing. You say you have no filters on. In your 1st screenshot, the list appears to be a much shortened list of performers than the default. Did you delete a bunch of performers or is that view being filtered...possibly by 'assigned' tags only? You say the 1st screenshot is from just loading the performers, but that screenshot starts at J and the 2nd screenshot starts at A. Did you post them in the wrong order?

Also, how many 'Tags per page' are you showing?
And what is your 'Thumbnail %' display setting in the bottom right of the status bar?


My apologies I do have my list set to "Assigned" instead of "All". I've had it that way since the start and it kinda become the default setting in my head. When I swap to all, I no longer get the issue. Just when under "Assigned".

As for the screenshots, I just uploaded them and submitted instead of using the inline function and the forum posted them in descending order instead of ascending. Since they were named though List 01, List 02 & List 03 I didn't worry about it. I have corrected that.

Tags per page is 50. Thumbnail and Zoom are 100%.
Sidebar.jpg
Sidebar.jpg (90.26 KiB) Viewed 96 times

User avatar
admineazymojo
Site Admin
Posts: 1000
Joined: Wed Jan 02, 2013 9:36 pm
Contact:

Re: Odd Sorting Issue - Adult (Performers)

Postby admineazymojo » Fri Jan 11, 2019 5:50 pm

Just to clarify...

Your 1st screenshot is the initial load of the page. The 2nd screenshot is you scrolling down that same page? You didn't navigate and come back, you didn't update anything, it's the same as the 1st screenshot, but you just scrolled down and those performers just popped up in the last column that weren't there in the 1st screenshot?

Also, what is your monitor size?

User avatar
Seneset
Posts: 5
Joined: Thu Jan 10, 2019 10:47 am

Re: Odd Sorting Issue - Adult (Performers)

Postby Seneset » Fri Jan 11, 2019 6:50 pm

Correct, I didn't navigate to a new tab. I just scrolled down using my middle mouse button far enough that page two loaded in additional profiles.

My monitor is 27" and set to a res of 1920 x 1080.

User avatar
admineazymojo
Site Admin
Posts: 1000
Joined: Wed Jan 02, 2013 9:36 pm
Contact:

Re: Odd Sorting Issue - Adult (Performers)

Postby admineazymojo » Fri Jan 11, 2019 8:00 pm

Ok, I believe I know what's causing it. It's very specific to your setup, that's why I'm not able to reproduce it. Your performer images are all about the same width, mine aren't. It's trying to use all the available space to show the images so when a performer has no image, it's able to place it in that last column area when it loads more data. But when you assign an image to a new performer, it takes up more space so it can't put it there anymore...unless the new image is also thin enough.

I'm guessing it wouldn't happen if you resized the display area by opening the side panel or resized the program window or even just changed the thumbnail %, so it wouldn't have room to append those images in that last column.

I'll try to fix it in the next release by enforcing a stricter sort order.

User avatar
Seneset
Posts: 5
Joined: Thu Jan 10, 2019 10:47 am

Re: Odd Sorting Issue - Adult (Performers)

Postby Seneset » Fri Jan 11, 2019 8:29 pm

I noticed early on the smaller downloaded images from IAFD get upscaled when you go to the "show performers info" page/tab. So I've been been slowly replacing the really blurry ones with a new image all of which were saved at a uniform 340 x 400. It's just amazing this was caused by my own minor form of OCD. :lol:

And thank you for your help.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests